hi Titchypink.
this is all i could find out,hope it helps you out.
Trackpad, trackball, or keyboard not working on a BlackBerry smartphone running BlackBerry OS 7.1 and earlier
Article Number: 000029640 First Published: April 26, 2017 Last Modified: April 26, 2017 Type: Support
Environment
- BlackBerry smartphones running BlackBerry OS version 6 to 7.1
- BlackBerry smartphones running BlackBerry Device Software 5.0
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Overview
In some situations, a BlackBerry smartphone with a trackpad or trackball may experience issues with sensitivity, latency, or scrolling. Additionally, the BlackBerry smartphone keyboard, or other buttons may be unresponsive.
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Cause
This issue might be caused by one of the following:
- The trackball/trackpad sensitivity needs to be adjusted.
- Make sure the trackball/trackpad is not affected by a software freeze or an application freezing.
- The BlackBerry Device Software is out of date and requires an update to resolve the trackpad, trackball or keyboard issue.
- The physical trackpad, trackball or keyboard hardware is malfunctioning.
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Resolution
Resolution for Cause 1
Complete the steps in Article
5447 to ensure the trackball/trackpad sensitivity is correctly.
Resolution for Cause 2
For BlackBerry smartphones running BlackBerry OS version 6 to 7.1 using a trackpad, complete the following:
- From the Home screen, select Options.
- Select Typing and Language.
- Select Trackpad Sensitivity.
- Ensure Audible Roll is selected.
- Rapidly roll the trackpad up, down, right, and left.
- If an audible click is heard while not responding, proceed to Resolution for Cause 4 as this could be a software related problem.
For BlackBerry smartphones running BlackBerry Device Software 5.0 using a trackball, complete the following:
- From the Home screen, select Options.
- Select Screen/Keyboard.
- Ensure Trackball Audible Roll is selected.
- Rapidly roll the trackball up, down, right, and left.
- If an audible click is heard while not responding, proceed to Resolution 4 as this could be a software related problem.
- If an audible click is not heard, the problem may be related to a hardware issue. Please contact the wireless service provider for additional steps.
If an audible click is not heard, the problem may be related to a hardware issue. Please contact the wireless service provider for additional steps.
Resolution for Cause 3
To update BlackBerry Device Software using BlackBerry Desktop Software see, Article
11320.
or
To update the BlackBerry Device Software on the BlackBerry smartphone visit
http://www.blackberry.com/update/
Resolution for Cause 4
Use the BlackBerry Virtual Expert diagnostics application. For more information, see Article
35973.if not try this link.
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