20 Most Recent Swisher Zt2560 Zero Turn Radius 60" Riding Mower Questions & Answers


You took it apart without taking notes/pictures on what went where?! Mucho intelligente!

You will have to pay for the schematic if you can get one.

Swisher Zt2560... | Answered on Aug 17, 2016


Hello,
My name is Dane and I am going to try to help you solve your problem. I've done a little research on this mower and I believe your problem could be your drive belt. Swisher Part number 6046 which is a 47" belt. I have found your operators manual at the following link:

http://www.swisherinc.com/manuals/PDF/ZT/ZT2560.pdf

I didn't know if you had the 06-046 model or the 07-152, but the belts are the same for each. Once a belt becomes worn they will give the symptoms you are discribing. You can replace the belt per this manual and all should be well.

I hope I've helped. If you found this information useful, please leave me some THUMBS UP as deserved. Thank you! Dane

Swisher Zt2560... | Answered on Aug 17, 2016


You remove the Pto clutch assy then you replace drive belt as that pulley would then down and off.

Swisher Zt2560... | Answered on Apr 10, 2015


Do not fill. It is not meant to be serviced. The level should be about 3/4 in. below the cap.

Swisher Zt2560... | Answered on Jan 03, 2015


Contact me at billurquhart@bellsouth.net and I will send diagram and instructions as attachment.

Swisher Zt2560... | Answered on Jan 03, 2015


Remove blade drive belt. turn each blade by hand. Sounds as if you have bearing problems. Each spindle has an upper and lower bearing of the same size. They are notorious for going out! You can get them at most any auto parts store. Also check the tensioner pulley bearing. They go out quite often. As for the jerking, make sure the two drive disengage rods are fully in. Check tension on drive belt and belt. These belts get worn quickly. Be sure to blow the trash and dirt from your mower after each use. Especially the Hydraulic motors and the mower deck. This will save you lots of trouble. If you wash the mower, be sure and run the blades and Hrdroes to get water dried from bearings and pulleys and belts.

Swisher Zt2560... | Answered on Jan 03, 2015


Was it working correctly earlier or is this your initial operation?

According to the product manual for "loss of drive":
1. Bypass linkages in the bypass position
2. Hydro belt worn, damaged, or broken
3. Idler spring loose or broken

1. Make sure that the bypass linkages are in
the drive or engaged position. Located at
the rear of the machine. Refer to decal on
the rear of the unit.
2. Replace Hydro belt.
3. Replace Idler spring

Swisher Zt2560... | Answered on Apr 16, 2014


YES IVE SEEEN IT BEFOR SOUNDS LIKE THE BELT IS LOOSE

Swisher Zt2560... | Answered on Nov 09, 2013

Not finding what you are looking for?
Swisher Zt2560 Zero Turn Radius 60" Riding Mower Logo

64 questions posted

Ask a Question

Usually answered in minutes!

Top Swisher Garden Experts

dannydoesita

Level 3 Expert

775 Answers

ray gallant

Level 3 Expert

66462 Answers

George Merkley
George Merkley

Level 2 Expert

194 Answers

Are you a Swisher Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Swisher Garden

  • Swisher Garden

Most Popular Question

replace top belt one directly beneath

  • Garden
Loading...