Question about Mercury Cars & Trucks

2 Answers

2007 Mercury mountaineer V8 Premier. Vehicle shut off on my husband after he pulled out of driveway, got it started back up after a few days, now the whole Dashboard panel lights work, other than blinking on every 3 seconds,I can't see what my mileage is. Would this be the instrumental cluster for dimmer switch? also the code reader was throwing off a battery connection code, ABS code, transmission malfunction. Check engine light has been on for a month now on the dash. The battery is not even a year old. Another possible cause question, my husband just hooked up a 31 inch led barlight for me before all of this chaos took place. To me it seems like an electrical over load,(seems like a reasonable cause) but that's me, or could it possibly be that my husbands big foot hit something lose lol, I mean it is hanging there right by his size 13 boot, and not harnessed up like it should be, he's been the only one driving it for the last 2 weeks, it had never given me any type of malfunctions when it was only me driving it, other then a random flat tire. I feel like it got in his way and he knocked the fuse lose, maybe possibly the same day it randomly shut off as he was driving a few minutes after leaving or driveway. I drove it to work everyday and to my children's school for the last 3 months not one thing was wrong with it except the only problem we both was aware of, and that's the transmission leak, he gets under the front passenger side of the vehicle somewhere between middle of the under belly and the passanger tire,and loosens the opening with a 1 3/8" socket everytime it needs a refill, and you have to pump it in to the resivour.(uncool spot for the fluid intake may I add, lol )very inconvenient for me when it needs more. At the time he was working out of town, so none was able to be added,( I can do a few small minor fixes on our vehicles without his help, but not that.) It got driven around longer than what we normally do, eventually a symbol of a wrench popped up, so now I have the check engine light on and the wrench symbol on. The dashboard is the only electrical problem we have noticed, everything else functions properly dome lights door lights radio lights, all correct lights come on when you open the doors just not dash lights. In the mean time we have leased a VW Jetta, but if this is an easy minor parts and labor fix that would be nice.

Posted by on

  • Brecklynn Whitman Feb 09, 2019

    I need to correct the beginning of my question.
    Were it says dashboard panel lights work!
    It's supposed to say, the dashboard panel lights Don't work other than blinking on every 3 second.

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Ground loose some were on the battery

Posted on Feb 09, 2019

Ad

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Master
  • 721 Answers

Im thinking a bad fuse in the fuse box start testing each and everyone

Posted on Feb 09, 2019

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Mikey108

Michael Zangari

  • 475 Answers

SOURCE: 2000 Jeep Wrangler Check Gauges Light on

If the alt.is bd, it will make your dash go crazy because now your running only on battery power. Not enough volts to run every electrical items

Posted on Nov 13, 2008

Anonymous

  • 512 Answers

SOURCE: 1995 Chrysler Concorde

the alarm is activating when he locks it and for some reason the key or fob isnt deactivating it..check the disarm switches in the door

Posted on Oct 01, 2008

Anonymous

  • 1118 Answers

SOURCE: Dash Instrument Panel Lights are dead - gauges work fine

do you have taillights? most of the time there on the same fuse. also chk. to see if plug is all the way in on your headlight switch.

Posted on Jan 21, 2009

Anonymous

  • 119 Answers

SOURCE: '01 Subaru Outback, ABS Light, BRAKE light & battery light

sounds like a open diode in alternator,when brake and battery lights come disconnect green plug on alternator,if the lights go out you've found the problem,very common problem with subarus

Posted on Jul 10, 2009

kirtec auto

  • 1348 Answers

SOURCE: transmission malfunction notifier message on

check the fluid and all the wiring plugs going to the transmission.it is not uncommon for oil to drip onto a plug and cause bad readings,or vacuum lines that are cracked.

Posted on Jul 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My airbag light on my 2002 mercury mountaineer continiously stays illuminated any reason why and how to fix it?


This is probably a seat sensor but it could be the pretensioners or the air bag. When the vehicle is started, there is a sensor test that is run on the SRS (air bag) and if it finds something wrong, the light comes on. Given that this is a life safety device and there are hazardous parts in it, you should take it to a dealer to have it worked on.

Mar 24, 2014 | 2002 Mercury Mountaineer

1 Answer

I need a diagram of the firing order for a 1997 montaineer


For the 1997 Mercury Mountaineer V8 5.0L Engine:

Firing Order:
1-3-7-2-6-5-4-8

Cylinders:
.......(back)......
|..4..|........|..8..|
|..3..|........|..7..|
|..2..|........|..6..|
|..1..|........|..5..|
.......(front)

Ignition Coil Connections:
(back)........(back)
|.4..7.|........|.3..5.|
|.8..2.|........|.6..1.|
(front)........(front)

Let me know if this helped, or if you have additional information or questions. Feel Free to contact me at FixYa.com!

May 01, 2010 | 1997 Mercury Mountaineer

2 Answers

02' Mercury Mountaineer 4WD V8 - High Temp & Low Oil Pressure


I am having the same problem. Changed the pressure switch and that didnt help.

Jan 01, 2009 | 2002 Saab 9-5

2 Answers

98 MercuryMountaineer..It Runs for about 5 Mins Then Cuts Off


it's a default sensor to keep from blowing motor, you need to check your radiator for leaks. If that doesn't fix the problem , change your alternator. :)

Nov 25, 2008 | 1998 Mercury Mountaineer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

gerry bissi

Level 3 Expert

4388 Answers

Marvin
Marvin

Level 3 Expert

85216 Answers

fordexpert

Level 3 Expert

5692 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...