Question about LG 42LC2D 42 in. LCD HDTV

5 Answers

LG LCD HDTV 'NO SIGNAL'

TV will be working fine, then all of a sudden, no picture and 'no signal' sign comes up. This can last anywhere from a few minutes to all day. Sometimes cable signal comes back, but still can't get digital or analogue signals.
Have had digital antenna installed. all other analogue tvs work as does cable in other room. Also, when this happens, if i try to watch recorded tv, i get a picture, but there is no sound.

Posted by on

  • 15 more comments 
  • Anonymous Dec 13, 2007

    TV will be working fine, then all of a sudden, no picture and 'no
    signal' sign comes up. This can last anywhere from a few minutes to all
    day. Sometimes cable signal comes back, but still can't get digital or
    analogue signals.
    Also have digital satellite antenna installed. all other analogue tvs work fine as does
    cable in other room.

  • Anonymous Dec 13, 2007

    LG 32LC56 will be working fine with my Sky HD, then all of a sudden, no picture and 'no signal' sign comes up. This can last anywhere from a few minutes to all day. If i reselect the HDMI1 on the TV the picture comes back.

  • Bluejed Dec 23, 2007

    LG 42" LCD with HD looses signal, if unit turned of then back on a few min later, god for 5 - 10min then same problem. Cheched signal through menu on TV Good whilst working then bad when signal lost

  • Anonymous Jan 15, 2008

    I am having this same problem with my 26 in. LG. I need to know if it's the tv or is a cable box problem. Comcast has offered to replace the digital cable box, but if it's the tv I need to return it.

  • aamee Feb 07, 2008

    I was watching nine all of sudden my remote didn't change channel and when it finally did, all Chanel's were gone , Digital channels come up as NO SIGNAL and analog is working fine tried to re-tune may times didn't fix the problem , it is strange that i can watch TV on analogue signal but not digital ?? If anyone can help would appreciate

  • Chrizzo Feb 25, 2008

    just goes black. Cant change input modes, then when its obvious its "crashed" you cant turn it off unless you hold the control off button for seconds..

    Turn off and let sit, turn it back on and it used to come back for 30 secs then its toast. Now nothing comes on...

  • Anonymous Mar 18, 2008

    My LG 42" HDTV just started doing the same thing. No Signal, Analogue TV video o.k but no sound and when you play a pre-recorded show, no sound also.

  • Anonymous Nov 20, 2008

    when attempting to watch a d.v.d. the screen says NO SIGNAL, however, i can hear the movie playing.

  • Anonymous Nov 27, 2008

    When ever I go to any channel that is not a cable channel it comes unclear. Then it say's No Signal Channel not availible. What's wrong help I'm dying to watch HDTV. My unHDTV has better signal.

  • Anonymous Nov 27, 2008

    My cables working fine. But other channels are like No Signal Channel Not Available.Help me I want to watch HDTV real bad. My unHDTV has better signal.

  • treimer Nov 28, 2008

    I have a new LG 52 inch LCD. Perfect under TV signal, but with Blu-ray, it occasionally (4-5 times per movie) decides there is no signal, shuts down, realizes there is a signal, turns back on. Lose about 30-45 seconds of the movie and must back up. it is definitely an issue where the TV thinks there is no signal. On the flip side, you can start a Blu-ray without even turning the TV on. Once it senses the signal, it turns itself on. Cool, but it will go back to the store if it cannot be fixed.





  • bubbe19 Jan 26, 2009

    My LG HDTV 47" is new. Working fine yesterday. Today when we turned it on today, it said DVI Alert: HDMI is blocked. It had another warning, but it went off the screen and now it only says "no signal". The DVD works and the TV remote works. We tried all the other HDMI's 1-4 but they all say no signal. The cable company says the HDMI wire burned out. But it is only 3 weeks old. and a monster cable. What can we do?

  • Anonymous Mar 07, 2009

    No screen. Cable is working fine on all other tv's in the house. The power goes on and off all on it's own.

  • wlcm2thdwn Apr 12, 2009

    My NEW TV was working fine, it's only been up for a wek the on Easter sunday the picture went blank except for a 'no signal' prompt. I had my old antennae on it do i need to go buy the new DTV antennae?

  • Anonymous May 02, 2009

    TV and PS3 working fne other than that nothing else work, Not even Direct Tv

  • shane guyton Nov 23, 2012

    my digital antenna does not work, for awhile I had to move it around a little to get a signa.Then I rescaned using a high dollar antenna, it was the same till I kept trying and now nothing at all.

  • Anonymous Mar 17, 2014

    Grundig tv digital program no sound but analogue there is sound picture ok

×

Ad

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

To fix the problem, try turning off the TV and unplugging it from the outlet. Once unplugged, push the power button and hold it down for 1 minute. Then turn the TV back on and rescan for channels.

If the problem persists, contact LG customer service immediately as there is a problem with the memory card. The device is unable to retain scanned channels for immediate feedback.

All LG LCD automatically comes with a 1 year manufacturing warranty. You would have to provide proof of purchase to show when it was purchased. Hope this helps. The Guru

LG customer service: http://www.lg.com/us/support/index.jsp

Posted on May 12, 2010

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 106 Answers

I have a 26" LG and this happens to me any time I unhook a cable from the back of the TV, HDMI or not!

It is NOT THE HDMI CABLE!

Make sure your TV has no Power and unhook every single cable from the back of your TV. (press the power button the make sure)

I left my Coax cable hooked up and I did not lose any channel information when the power was off but I did this pretty quick!

Once everything is unhooked from the back of your TV, reattach everything! (I know it sounds stupid but it works for me.)

Once you have attached all the cords again, turn the TV back on and you should have your HDMI again!

I don't know why this happens but I lose my HDMI on both Connections just by removing my Coaxial Cable Connection! TV/Comptuer/VCR all come in fine with Coax/RGB/RCA connections but I lose both HDMI untill I do the process listed above.

I should note that I have had this issue with other TV manufacturers as well, it seems to be an issue with HDMI itself.

Cheers

Posted on May 27, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I. Turn the TV back on and rescan for channels on input from Comcast Cable using RCA component cables i.e. red, yellow, blue, green, and white
A. Choose 'Components' as imput source
1. Choose 'No' to scan from existing channels
2. Choice of 'Antenna' or 'Cable' shows 'Antenna' but default and will not move to option Cable image
3. Scanning begins with '0' channels stored
4. Batteries in Remote Control seem charged
II. I have Alternate HDMI 1 and 2 Ports open in Monster Wire
A. I note there is a antenna and cable button on the bottom left corner of the back of the television and am controls the remote?
III. The Amplifier is on auxillay and I can hear television channels coming directly from the Comcast Cable Box by changinging the comcast cable Remote Control. All televions in the ouse have a picture.

Conclusion LG 'No Signal" is a problem with the television.

Lucky

Posted on Jul 27, 2010

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

If it still under warranty get intouch with LG-if not looks like (if its definitely not your input signal) theres a problem on the mainboard- if theres a firmware fix for the issue youll have to look into as there are many forums with ppl who have problems like this

Posted on Dec 18, 2007

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • LG Expert
  • 158 Answers

Factory reset the tv and located the router box

Posted on Sep 03, 2015

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Sony TV not connecting to internet is a sudden thing over the last few days, been working fine for a couple of years. Have switched off and unplugged to no avail?


If your network is up and all else is working fine with the Sony it could be that the circuit that detects the wi fi signal is fubar.

Sep 17, 2017 | Sony Televison & Video

1 Answer

VIZIO 42 CLASS RAZOR LED SMART TV M420KD picture has lots of green ghosting and thin white vertical line through left side of screen also


Hi Charlene,

please try with video input from any device,and i think you are using local antenna and it has gain problem or your tuner section of the tv is not working correctly.
if distroted pictures comes with video input signal it is video amp and processing unit problem.
you have to go for repair shop for fix that.
regards,
nuwan

Jan 24, 2014 | Vizio Televison & Video

1 Answer

Mitsubisho WS-55908: Cable coming in can be plugged into either "ANT-A" or "ANT-B". What happens now is that the signal goes out for a few minutes at a time, usually after I change a channel. This also...


You might have a bad regulator on the signal board or a bad button on the front of the tv. The AV RESET button will make the screen go black and if it is malfunctioning can cause this symptom. Bad solder (cracks) can also cause this. Lastly I have changed a few regulator for different problems. Near the back left side (while behind tv) on a small heatsink. Goodluck.

Jul 05, 2010 | Mitsubishi WS-55809 55" Rear Projection...

1 Answer

Just starte last day - turn on TV, (Sears model)


Bad solder on the mother board, chinese were sleeping, or bad tuner or processor chip due to temperature, Sorry pro help needed...


please rate!

Jul 10, 2009 | Televison & Video

1 Answer

Pioneer SD-582HD5 - screen went black, no sound, Poor remote feed


The blue tube might be leaking coolant in the high voltage area, that is the cause of the POP. This repair might not be a DIY because of the lethal high voltage surrounding the CRTs tubes.
The slow response from the remote could be because the coolant has affected the main board where the IR signal are going to the remote sensor.
Let me know if you require further assistance.

Dec 20, 2008 | Pioneer SD-582HD5 58" Rear Projection...

1 Answer

Olevia 242T 42" LCD HDTV - Suddenly No Picture, Nothing Works


 I heard they were restructuring their company or something.
There has been a change ownership from Syntax-Brillian to Olevia International Group.
Details of Olevia brand  
Unfortunately for all of us (we have 747i) service seems very poor and the failure mode you describe doesn't give me any clues despite 40+ years of service experience.
Ours is still 100% but I now suspect our trouble will come.

Nov 03, 2008 | Olevia LT42HVi 42 in. LCD Television

1 Answer

LG DU-42PX12X Plasma, picture startes flashing then goes black after a few minutes


You need to get this tv service asap.i beleive that the problem is in the inverter board or yb board.


good luck

caypianan@yahoo.com

Oct 25, 2008 | LG 42PX5D 42 in. Plasma HDTV

1 Answer

My new LG LCD TV (3 days old!) suddenly started playing up, last night. I was initially using the receiver unit (with built-in DVD) to play a disc of MPG files, which it did successfully. Then, I tried to...


Good thing the tv is under warranty, theres no magical fix for a problem like this. I would either return it to the store or call for service. If you atempt to do to much to fix it you might voide the warranty, and you should have to do anything to fix it as you said its 3 days old.

Tim Nolan

Sep 24, 2008 | Televison & Video

1 Answer

Picture is gone! :*(


the picture tube (what makes the TV picture work) has blown out. Just call you nearest tv reapair shop and purchase a new one. (these are kind of expensive!)

(Also, if it's fifteen years old, i think it's time to get a new T.V. hint. hint.)

Jul 03, 2008 | Zenith C27A24T 27" TV

1 Answer

Tv lost color


Your problem most likely is on the signal board is my guess. If your not a technician it would be in your best interest to have him check L2C60 on the signal board.

Nov 19, 2007 | Mitsubishi VS-60707 60" Rear Projection...

Not finding what you are looking for?
LG 42LC2D 42 in. LCD HDTV Logo

38,828 people viewed this question

Ask a Question

Usually answered in minutes!

Top LG Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76001 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18429 Answers

Steve Allison
Steve Allison

Level 3 Expert

5569 Answers

Are you a LG Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...